تكنولوجيا

كيفية التحقق من تسربات DNS وتسريبات WebRTC: التشخيص من 6 خطوات والحل حسب السبب

تسرب DNS هو ظاهرة تخرج فيها استعلامات DNS فقط من نفق VPN، وتسريب WebRTC هو ظاهرة تترك فيها طلبات STUN الوكيل، مما يكشف عن عنوان IP الحقيقي. نلخص التشخيص المكون من 6 خطوات باستخدام المتصفح فقط، والحلول لثمانية أسباب، وطرق التعامل مع تطبيق StageVPN وملحق Chrome.

فريق StageVPN22 دقيقة قراءة

رسم توضيحي ثلاثي الأبعاد يصور قطعة صغيرة من الضوء تتسرب من ممر أزرق على شكل أنبوب.

إذا رأيت أيًا من الأعراض الموضحة أدناه حتى بعد تشغيل VPN، فاشتبه في وجود تسرب DNS أو تسرب WebRTC. يحدث التسرب عندما تغادر المعلومات التي من المفترض أن تمر عبر مسار VPN هذا المسار (يُسمى أيضًا بالتسرب).

  • يتم عرض عنوان IP لخادم VPN في صفحة التحقق من IP، ولكن يتم عرض خادم DNS الخاص بشركة الاتصالات أو جهاز التوجيه في اختبار DNS.
  • لقد تغير عنوان IPv4، لكن عنوان IPv6 هو نفسه الذي كان عليه قبل إيقاف تشغيل VPN.
  • في صفحة اختبار WebRTC، يظهر عنوان IP العام كما كان قبل إيقاف تشغيل VPN.
  • لا يكون عنوان IP الأصلي مرئيًا إلا فور التبديل من Wi-Fi إلى بيانات الهاتف المحمول أو الاستيقاظ من وضع السكون.
  • لقد قمت بتشغيل StageVPN لمتصفح Chrome، لكن المتصفحات الأخرى وبرامج الكمبيوتر تتصل باستخدام عنوان IP الأصلي.
  • حتى مع تشغيل VPN، يعرض الموقع اللغة والمحتوى بناءً على المنطقة الأصلية (قد يكون هذا بسبب إعدادات الحساب/ملفات تعريف الارتباط).

تسرب DNS هو ظاهرة يمر فيها اتصال الويب عبر النفق عند تشغيل VPN، لكن استعلامات DNS فقط تخرج من النفق، ويكون اسم المجال مرئيًا لخادم DNS الخاص بشركة الاتصالات أو شبكة Wi-Fi. يعد تسرب WebRTC ظاهرة يرسل فيها WebRTC للمتصفح طلب STUN مباشرة من VPN/الوكيل، مما يسمح لصفحة الويب باكتشاف عنوان IP العام الفعلي. ولا تعني أي من الظاهرتين أن محتوى الصفحة يتسرب. ومع ذلك، فإنه يكشف "من يمكنه الوصول إلى أين". تبدأ هذه المقالة بالأعراض وتستمر عبر ست مراحل من التشخيص، والحل حسب السبب، وإعادة الفحص.

على الرغم من أن حركة مرور الويب محمية، إلا أن استعلامات DNS فقط هي التي تخرج.
على الرغم من أن حركة مرور الويب محمية، إلا أن استعلامات DNS فقط هي التي تخرج.

التشخيص: كيفية التحقق من وجود تسرب في 6 خطوات

مبدأ فحص التسرب هو مقارنة القيم مع إيقاف تشغيل VPN وتشغيلها. قارن عنوان IP الظاهر على الموقع، والخادم الذي تلقى استعلام DNS، وعنوان مرشح WebRTC. إذا كانت القيم الأصلية مرئية حتى بعد تشغيل VPN، فهذا تسرب. الاختبار مفيد فقط على الأجهزة والمتصفحات التي تستخدمها بالفعل. حتى لو لم يكن لديك موقع اختبار محدد، يمكنك التحقق من معظم الأشياء فقط باستخدام المتصفح. صفحة التحقق من IP هي صفحة ويب تعرض عنوان IP العام للشخص المتصل على الشاشة. يمكنك العثور عليه في محرك البحث باسم "التحقق من IP". ابحث عن صفحة اختبار تسرب DNS وصفحة اختبار WebRTC بنفس الطريقة. المبدأ هو نفسه بغض النظر عن الصفحة التي تستخدمها، لذلك لا يتعين عليك الاعتماد على موقع معين.

  1. قم بإيقاف تشغيل VPN وتسجيل IP الخاص بك. افتح صفحة التحقق من IP واكتب عنوان IPv4 العام، وعنوان IPv6، إذا كان موجودًا. هذه القيمة هي الأساس لجميع المقارنات اللاحقة.
  2. قم بتشغيل VPN الخاص بك وقارن عناوين IP. بعد التحقق من مؤشر اكتمال الاتصال على تطبيق StageVPN أو مؤشر التشغيل الأخضر على أيقونة StageVPN لمتصفح Chrome، افتح نفس الصفحة مرة أخرى. يجب استبدال IPv4 بعنوان خادم VPN الخاص بك.
  3. تحقق من خادم DNS الخاص بك. افتح صفحة اختبار تسرب DNS. تستعلم هذه الصفحات عن نطاقات فرعية عشوائية ثم تعرض خادم DNS الذي أرسل الاستعلام. إذا كان بإمكانك رؤية خوادم مشغل شبكة الجوال أو جهاز التوجيه الخاص بك، فهذا تسرب لنظام أسماء النطاقات (DNS).
  4. افتح الكروم: //webrtc-internals. سيؤدي إدخال هذا العنوان في شريط عناوين Chrome إلى عرض اتصالات WebRTC الحالية والعناوين المرشحة. سيظهر العنصر إذا كانت لديك صفحة اختبار WebRTC أو صفحة مكالمة الفيديو مفتوحة في علامة تبويب أخرى.
  5. تحقق من عنوان IP المرشح. إذا كان عنوان مرشح srflx (انعكاس الخادم) هو نفس عنوان IP العام الأصلي من الخطوة 1، فهذا يعني تسرب WebRTC. إذا كان عنوان IP لخادم VPN أو كان الاسم المحلي وعنوان IP الخاص فقط مرئيين، فلن يتم الكشف عن عنوان IP العام.
  6. تحقق من IPv6. إذا كان لديك عنوان IPv6 في الخطوة 1، فقم بتشغيل VPN ومعرفة ما إذا كان هذا العنوان قد اختفى أو تغير. إذا كان الأمر كذلك، فإن IPv6 سيغادر النفق. قم بالتبديل بين Wi-Fi وبيانات الجوال، وكرر ذلك لمعرفة ما إذا كانت النتائج هي نفسها بعد إعادة تشغيل المتصفح.
الجدول 1. كيفية قراءة نتائج التشخيص
نتائج المراقبةمعنىالسبب التالي
IP خادم VPN مرئي في الموقعتمر اتصالات الويب عبر مسار VPNعادي، الخطوة التالية
لقد تغير IPv4، لكن IPv6 هو العنوان الأصليIPv6 يترك النفقالسبب 2
خادم DNS من شركة الاتصالات أو جهاز التوجيه.تسرب DNSالأسباب 1، 3، 4، 5
خادم DNS هو مزود DNS العامDNS في تكوين VPN الخاص بك أو DNS الآمن الذي تحدده بنفسك.لا تفترض أنه تسرب بناءً على اسم النشاط التجاري فقط، تحقق من السبب رقم 4
عنوان IP العام الأصلي مرئي في WebRTCتسرب WebRTCالأسباب 6 و 7
تظهر فقط الأسماء .local أو عناوين IP الخاصة في WebRTCلا يتم كشف IP العامطبيعي بشكل عام
IP الأصلي فقط مباشرة بعد تبديل الشبكةالفجوة في لحظة التحولالسبب 8

قد تختلف النتائج حسب موقع الاختبار. هناك أماكن تعرض IPv4 فقط وأماكن تعرض IPv6، كما تختلف طرق البحث عن خوادم DNS. قارن في أكثر من مكان وبالتحويل إلى شبكات متعددة.

ماذا يكشف استعلام DNS؟

تحتوي استعلامات DNS على أسماء النطاقات. لا يتم تضمين محتوى الصفحة أو القيم المدخلة. DNS هو نظام دفتر عناوين الإنترنت الذي يحول أسماء النطاقات التي يقرأها البشر إلى عناوين IP تستخدمها أجهزة الكمبيوتر. في كل مرة تكتب فيها عنوانًا في متصفحك أو يتصل أحد التطبيقات بخادم، يسأل جهازك أولاً خادم DNS "ما هو عنوان هذا الاسم؟" لذا، بمجرد النظر إلى سجل الاستعلامات، يمكنك معرفة الكثير عن الوقت والخدمة التي حاولت الوصول إليها.

  1. جهازيالتطبيق/المتصفح
  2. خدمة الواي فاي العامةراوتر مقهى
  3. DNS الناقلالخادم الموجود
  • المناطق التي من الممكن أن تتعرض لها
الشكل 1. عندما يكون هناك تسرب لنظام DNS: تمر اتصالات الويب عبر النفق، لكن استعلامات DNS تخرج إلى الشبكة الحالية.
  1. جهازيالتطبيق/المتصفح
  2. خدمة الواي فاي العامةراوتر مقهى
  3. خادم VPNStageVPN
  4. خادم DNSحدد في تكوين VPN
  • تشفير VPN
الشكل 2. بدون تسريبات: تنتقل استعلامات DNS أيضًا إلى النفق، ويرى خادم DNS عنوان IP الخاص بخادم VPN.

تنتقل استعلامات DNS التقليدية إلى منفذ UDP 53 غير مشفر. للتعويض عن ذلك، تم إنشاء DoH (RFC 8484)، الذي يغلف الاستعلامات في HTTPS، وDoT (RFC 7858)، الذي يغلف الاستعلامات في TLS. ومع ذلك، حتى إذا كنت تستخدم DNS مشفر، فإن اسم الخادم (SNI) الذي يتم إرساله عند الاتصال بموقع عبر HTTPS قد يكون مرئيًا على الشبكة إذا كان الموقع والمتصفح لا يدعمان ECH (مرحبًا بالعميل المشفر).

الجدول 2. أين يمكن العثور على أسماء النطاقات عن طريق طريقة إعادة توجيه DNS.
طريقة التسليممراقب على نفس الواي فايمشغل شبكة Wi-Fi/شركة اتصالاتخادم DNS يتلقى الاستعلام
DNS عادي (نص واضح)يمكن أن نرىيمكن أن نرىمرئية، مع IP العام الخاص بي
DoH/DoT (DNS المشفر)لا أستطيع أن أرىغير مرئية، عناوين خادم DNS مرئيةمرئية، مع IP العام الخاص بي
DNS داخل نفق VPNلا أستطيع أن أرىغير مرئي، يرى فقط أنه يتصل بخادم VPNمرئية، مع IP خادم VPN
حالة تسرب DNSإذا كان نصًا عاديًا، فيمكنك رؤيته.يمكن أن نرىمرئية، مع IP العام الخاص بي

DNS الآمن (DoH) وVPN لهما أغراض مختلفة. تقوم DoH بتشفير استعلامات DNS فقط؛ يظل الوصول إلى الموقع نفسه وعناوين IP التي يراها الموقع كما هو. تقوم VPN بتشفير الاتصال بالكامل بين جهازك أو متصفحك وخادم VPN وتغيير عنوان IP الذي تراه المواقع. وضع التصفح المتخفي لا يوقف التسريبات أيضًا. وضع التصفح المتخفي هو وظيفة لا تترك سجلاً أو ملفات تعريف الارتباط على الجهاز، ولا تغير استعلامات DNS أو مسارات WebRTC.

كيف يحدد WebRTC عنوان IP؟

يجد WebRTC عنوانه الخاص بعدة طرق لتوصيل جهازين عبر أقصر مسار ويمرر النتائج إلى البرنامج النصي على صفحة الويب. WebRTC هي تقنية قياسية على الويب تتيح لك إجراء مكالمات فيديو ومكالمات صوتية ونقل الملفات بدون مكونات إضافية في متصفحك. تسمى عملية جمع العناوين ICE (RFC 8445). حتى الصفحات التي لا تجري مكالمات فيديو يمكنها بدء هذه العملية باستخدام برنامج نصي.

  1. إنشاء كائن اتصاليقوم البرنامج النصي لصفحة الويب بإنشاء RTCPeerConnection
  2. جمع المرشحين المحليينيقوم متصفحك بجمع عناوين أجهزة الشبكة الخاصة بجهازك
  3. استعلام STUNاسأل خادم STUN "كيف يبدو عنواني" باستخدام UDP
  4. تسليم المرشحيتم تسليم قائمة المرشحين بما في ذلك العناوين العامة المقدمة من خادم STUN إلى الصفحة.
الشكل 3. الترتيب الذي يجمع به WebRTC عناوين الاتصال المرشحة (ICE)
الجدول 3. أنواع مرشحات اتصال WebRTC والمعلومات التي يمكن الكشف عنها
نوع المرشحشئ ماالمعلومات التي قد يتم الكشف عنهاحماية المتصفحات الحديثة
يستضيفعنوان جهاز الشبكة الخاص بالجهازعنوان IP الخاص (192.168.x، وما إلى ذلك)مقنع باسم .local عشوائي (mDNS)، ولكن يمكن رؤيته على المواقع التي منحت أذونات الكاميرا والميكروفون.
srflx (انعكاس الخادم)عنواني العام كما يراه خادم STUNIP العام، IP الحقيقي إذا قمت بتجاوز الوكيليمكن تقييده بواسطة سياسة معالجة WebRTC IP
تتابعTURN عنوان خادم الترحيلترحيل خادم IPإذا كنت تستخدم التتابع، فسيرى الطرف الآخر عنوان الخادم بدلاً من عنوان IP الخاص بك.

تكمن المشكلة في استعلام STUN في الخطوة 3. يقوم وكلاء المتصفح بإعادة توجيه طلبات الويب، لكن اتصالات UDP الخاصة بـ WebRTC لا تمر عبر الوكيل في الإعدادات الافتراضية للمتصفح. لذا فإن العنوان الذي يقدمه خادم STUN ليس هو الخادم الوكيل، ولكنه عنوان IP العام الأصلي الخاص بي. تختلف الأمور مع شبكات VPN على مستوى الجهاز. نظرًا لأن جميع اتصالات UDP، بما في ذلك طلبات STUN، تنتقل إلى النفق، فإن العنوان الذي يراه خادم STUN هو أيضًا عنوان IP الخاص بخادم VPN.

وكيل المتصفح والسياسة الافتراضية

  • تمر طلبات الويب عبر وكيل
  • تذهب طلبات STUN مباشرة إلى UDP
  • يمكن للصفحة رؤية IP العام الحقيقي

وكيل المتصفح وdisable_non_proxied_udp

  • منع UDP من المرور عبر الوكيل
  • يستخدم WebRTC مسارات الوكيل فقط
  • تحتوي بعض المكالمات على طرق اتصال أو جودة مختلفة

VPN على مستوى الجهاز

  • تمر طلبات STUN أيضًا عبر النفق.
  • مرشح العنوان العام هو IP خادم VPN
  • يتطلب قطع الاتصال ومعالجة IPv6 تأكيدًا
الشكل 4. احتمالية تسرب WebRTC اعتمادًا على طريقة الاتصال

لدى Chrome "سياسة التعامل مع WebRTC IP" التي تحدد العنوان الذي سيستخدمه WebRTC، ويمكن للإضافات تغيير هذه القيمة. تتوافق كل قيمة مع أربع طرق موضحة في توصية معالجة عنوان WebRTC IP الخاصة بـ IETF (RFC 8828).

الجدول 4. قيم سياسة التعامل مع WebRTC IP في Chrome (استنادًا إلى chrome.privacy API)
قيمة السياسةحركةنطاق التعرض
تقصيرجمع المرشحين من جميع أجهزة الشبكةالأوسع (العناوين المحلية المقنعة بواسطة mDNS)
default_public_and_private_interfacesاستخدم الأجهزة الموجودة على المسار الافتراضي فقط، واستخدم العناوين العامة والخاصةلا يعرض عناوين الأجهزة الأخرى
default_public_interface_onlyاستخدم فقط العناوين العامة للمسار الافتراضيلا يتم كشف العناوين الخاصة
Disable_non_proxied_udpلا يوجد UDP من خلال الوكيل، استخدم TCP من خلال الوكيل إذا كان الوكيل لا يدعم UDPلا تكشف عن عناوين الطرق خارج الوكيل
إجراء التحقق باستخدام متصفح فقط دون موقع محدد
إجراء التحقق باستخدام متصفح فقط دون موقع محدد

الحل: كيفية التحقق والإصلاح حسب السبب

معظم التسريبات لها سبب من ثمانية أسباب: يحدث هذا عادةً بسبب تداخل الإعدادات. ابدأ بالتحقق من رقم السبب المشار إليه في جدول التشخيص، وفي كل مرة تقوم فيها بإصلاح أحد الأسباب، كرر الخطوة 6 في الصورة أعلاه لمعرفة ما إذا كانت النتيجة قد تغيرت. إذا قمت بتغيير عدة إعدادات في وقت واحد، فلن تعرف ما الذي نجح.

السبب 1 · لا يوجد خادم DNS في تكوين VPN أو أن الجهاز يستخدم DNS مختلف.

يفحص مع تشغيل VPN، يُظهر اختبار DNS جهاز توجيه Wi-Fi أو خادم DNS الخاص بشركة الاتصالات. غالبًا ما يكون لديك DNS يدوي في إعدادات Wi-Fi بجهازك.

يحل يتضمن تطبيق StageVPN خادم DNS في تكوين VPN ويرسل الاستعلامات إلى النفق. قم بإرجاع DNS اليدوي إلى الوضع التلقائي في إعدادات شبكة جهازك، ثم افصل شبكة VPN وأعد الاتصال بها. إذا ظلت المشكلة كما هي، فتحقق من السببين 3 و5.

السبب 2 IPv6 يخرج عن النفق

يفحص تم تغيير IPv4 إلى عنوان خادم VPN، لكن IPv6 يظل كما هو كما هو مكتوب في الخطوة 1. إذا كانت شبكة VPN تقوم فقط بأنفاق IPv4، فسوف تخرج استعلامات IPv6 واتصالاتها عن المسار الأصلي.

يحل تم تكوين تطبيق StageVPN لإرسال اتصالات IPv6 إلى النفق أيضًا (AllowedIPs 0.0.0.0/0,:/0)، لذلك ليست هناك حاجة عادةً لإيقاف تشغيله. إذا ظل IPv6 يظهر كما ينبغي، فتحقق أولاً لمعرفة ما إذا كان تطبيق VPN آخر أو إعدادات الجهاز تغير المسار. بعض مواقع الاختبار لا تدعم IPv6، لذا قارن بين أكثر من موقع.

السبب 3 · يقوم نظام التشغيل بالاستعلام عن DNS لأجهزة الشبكة المتعددة في وقت واحد.

يفحص خاصة أثناء اتصال VPN على جهاز كمبيوتر يعمل بنظام Windows، يُظهر اختبار DNS كلاً من DNS الخاص بشبكة VPN وDNS الخاص بشركة الاتصالات الخاصة بك. يحدث هذا بسبب ميزة تطلب من كافة أجهزة الشبكة في وقت واحد، مثل ميزة تحليل الأسماء الذكية متعددة المنازل لنظام التشغيل Windows.

يحل حافظ على تحديث نظام التشغيل وبرنامج VPN الخاص بك وكرر الاختبار. يتم الإبلاغ عن هذه الظاهرة بشكل أساسي مع شبكات VPN على مستوى الجهاز على أجهزة الكمبيوتر، ولا تحدث بنفس الطريقة على تطبيق StageVPN على الهواتف الذكية وStageVPN لمتصفح Chrome على Chrome نظرًا لاختلاف الهياكل.

السبب 4 · يتم تحديد DNS الآمن (DoH) بشكل منفصل في المتصفح أو الجهاز

يفحص يُظهر اختبار DNS خوادم من موفري DNS العامين. في هذه الحالة، قد لا يكون الأمر تسربًا، بل هو إعداد قمت بتحديده بنفسك. إذا كان لديك شبكة VPN على مستوى الجهاز، فسيمر هذا الاستعلام أيضًا عبر النفق، ولكن سيتم استلامه بواسطة الموفر المحدد بدلاً من DNS في تكوين VPN الخاص بك.

يحل إذا كان هذا هو الإعداد المقصود، فيمكنك تركه كما هو. إذا كنت تريد استخدام DNS لتكوين VPN الخاص بك، فسيقوم تلقائيًا بتغيير إعدادات DNS الآمنة على متصفحك وجهازك. من المهم عدم افتراض أنه تسرب بمجرد النظر إلى اسم النشاط التجاري.

السبب 5 · يتم أيضًا تشغيل تطبيقات VPN والوكيل والأمان الأخرى

يفحص يتم تشغيل ميزات الشبكة لتطبيقات VPN الأخرى أو ملحقات الوكيل أو عوامل تصفية الإعلانات أو برامج الأمان في نفس الوقت. تقوم إعدادات المسار بالكتابة فوق بعضها البعض، مما يتسبب في انتقال بعض الاستعلامات إلى المسار الأصلي.

يحل قم بتشغيل واحد فقط في كل مرة. قم بإيقاف تشغيل التطبيقات والإضافات الأخرى، وافصل StageVPN وأعد توصيله، وكرر الخطوة 6. يمكن لإعدادات الوكيل في Chrome التحكم في ملحق واحد فقط في كل مرة، لذلك إذا كان ملحق آخر يستخدم وكيلاً، فلن يتصل StageVPN لمتصفح Chrome وسيخبرك بالسبب.

السبب 6 · يتم استخدام وكيل المتصفح فقط، ولكن من المتوقع الاتصال خارج المتصفح

يفحص لقد قمت بتشغيل StageVPN لمتصفح Chrome، لكن المتصفحات الأخرى وبرامج المراسلة على أجهزة الكمبيوتر وبرامج البريد تتصل باستخدام عنوان IP الأصلي وDNS الأصلي. هذا ليس تسربًا، هذا هو النطاق المصمم. يغطي الامتداد الاتصال في Chrome فقط.

يحل إذا كنت بحاجة إلى حماية البرامج خارج Chrome، فاستخدم VPN الذي ينطبق على الجهاز بأكمله. على الهواتف الذكية، يقوم تطبيق StageVPN بذلك. الفرق في النطاق بين الطريقتين هو متصفح VPN مقابل تطبيق VPNلقد نظمته في .

السبب 7 لم يتم تطبيق سياسة WebRTC

يفحص لقد قمت بتشغيل StageVPN لمتصفح Chrome ويمكنني رؤية عنوان IP العام الأصلي في اختبار WebRTC أو في مرشح srflx في chrome://webrtc-internals. إذا كانت إحدى الإضافات أو سياسة إدارة الشركة/المؤسسة تتحكم في إعدادات WebRTC أولاً، فلن يغير StageVPN لمتصفح Chrome السياسة وسيتركها كما هي.

يحل قم بإيقاف تشغيل أي ملحقات أخرى تتحكم في إعدادات WebRTC وأعد توصيل StageVPN لمتصفح Chrome. إذا كانت سياسة الإدارة هي السبب، فاتصل بالمسؤول. للكتابة في نافذة التصفح المتخفي، يجب عليك تشغيل "السماح في وضع التصفح المتخفي" في شاشة إدارة الإضافات. عند إيقاف التشغيل، لا تمر الاتصالات في نوافذ التصفح المتخفي عبر الوكيل.

السبب 8 · لحظة فقدان اتصال VPN

يفحص لا يكون عنوان IP الأصلي مرئيًا إلا فور تبديل الشبكات أو الاستيقاظ من وضع السكون، وبعد فترة يصبح الأمر طبيعيًا. أثناء قطع الاتصال، تخرج جميع الاستفسارات والاتصالات عبر المسار العادي.

يحل قبل القيام بأي عمل حساس، تحقق مما إذا كان مؤشر اكتمال اتصال التطبيق أو رمز الامتداد قيد التشغيل. لا يقوم WireGuard، الذي يستخدمه تطبيق StageVPN، بإعادة إنشاء النفق حتى عند التغيير من Wi-Fi إلى LTE، لكن البروتوكول لا يمكنه التعويض عن انقطاع الاتصال المؤقت في الشبكة نفسها. إن القدرة على حظر الاتصالات تلقائيًا عند قطع اتصال VPN ليست ميزة توفرها StageVPN. المبدأ هو شرح مبادئ WireGuardإنه في

كيف توقف تطبيقات StageVPN وStageVPN لمتصفح Chrome التسريبات؟

يعمل تطبيق StageVPN على تقليل التسرب عن طريق توجيه جميع الاتصالات، بينما يقوم تطبيق StageVPN لوكلاء Chrome بعمليات البحث عن الأسماء وضبط سياسات WebRTC. ونظرًا لاختلاف نطاق الحماية، فإن طريقة التعامل معها مختلفة أيضًا.

الجدول 5. معالجة DNS/WebRTC لتطبيق StageVPN وStageVPN لمتصفح Chrome (اعتبارًا من سبتمبر 2026)
غرضتطبيق StageVPN (iPhone · iPad · Android)StageVPN لمتصفح Chrome
نطاق الحمايةجميع الأجهزةمتصفح كروم
الاتصالات المرسلة عبر طريق VPNIPv4·IPv6 الكل (عناوين IP المسموح بها 0.0.0.0/0، ::/0)تمر طلبات الويب عبر الوكيل (باستثناء نطاقات IP الخاصة والمضيف المحلي)
استعلامات DNSقم بالتوجيه داخل النفق إلى خادم DNS المحدد في تكوين VPN.لا يتم البحث عن الطلبات التي تمر عبر الخادم الوكيل بواسطة Chrome، بل بواسطة الخادم الوكيل.
WebRTCتمر جميع اتصالات UDP عبر النفق.يتم تطبيق Disable_non_proxied_udp أثناء الاتصال، ويعود إلى الإعداد الأصلي عند قطع الاتصال.
ما تراه حاليا على الشبكةحقيقة وجود اتصال مشفر مع خادم VPN وكمية البياناتالبحث عن أسماء عناوين الخادم الوكيل، والاتصالات المشفرة مع الوكيل، والاتصالات من تطبيقات خارج Chrome
الحالات التي قد لا تنطبقأثناء فقدان اتصال VPN، عند إعادة توجيه تطبيق VPN آخرنافذة التصفح المتخفي مع إيقاف تشغيل السماح بوضع التصفح المتخفي عندما يتحكم ملحق آخر أو سياسة إدارة أخرى في إعدادات الخادم الوكيل/WebRTC
سجل الوصول (93 يومًا)لا يتم تسجيل المجالات التي تم عرضهايتم تسجيل اسم مضيف الوجهة المتصل، ولكن لا يتم تسجيل المسار أو مصطلح البحث.

لا يرشدك StageVPN عبر قائمة إعدادات حماية تسرب DNS المنفصلة كميزة لعروضه. يعتمد السلوك أعلاه على تكوين VPN الافتراضي للتطبيق وطريقة اتصال الامتداد. نطاق الحكم هو الميزات ونطاق العرضيمكنك التحقق من ذلك هنا.

عدم وجود تسريبات يعني أن الاستعلامات والاتصالات تمر عبر مسار VPN بدلاً من الناقل. هذا لا يعني أنه لن يتم الاحتفاظ بأي سجلات. تحتفظ StageVPN بسجلات الوصول لمدة 93 يومًا وفقًا لقانون حماية أسرار الاتصالات ولا تسجل محتوى الاتصالات. هذا البند هو الوصول إلى إشعار تخزين السجلاتحسنًا، السبب وراء الكشف عن ذلك هو لماذا نكشف عن سياسة الاحتفاظ بسجلات الوصول الخاصة بنا؟وأوضح.

كيف تمنع كل من التطبيقات والإضافات التسريبات
كيف تمنع كل من التطبيقات والإضافات التسريبات

قائمة إعادة التحقق: ما الذي تعيد التحقق منه بعد إجراء التغييرات؟

في كل مرة تقوم فيها بإصلاح سبب واحد، تحقق من العناصر أدناه مرة أخرى من البداية. إذا مر كل شيء، فلا يوجد تسرب. إذا فشل أي عنصر، فإنه يعود إلى بطاقة السبب المقابلة.

  • بعد قطع الاتصال بشبكة VPN وإعادة توصيلها، تحققت مما إذا كان التطبيق قد أظهر اكتمال الاتصال أو أن رمز التوسيع ظهر قيد التشغيل.
  • في صفحة التحقق من IP، سترى إما عنوان خادم VPN لكل من IPv4 وIPv6، أو لن ترى IPv6.
  • لا يُظهر اختبار DNS خادم DNS الخاص بشركة الاتصالات أو جهاز التوجيه.
  • لا يمتلك مرشح srflx في chrome://webrtc-internals عنوان IP العام الأصلي.
  • يتم إيقاف تشغيل ميزات الشبكة لتطبيقات VPN الأخرى والوكلاء/ملحقات VPN وبرامج الأمان.
  • إذا قمت بتعيين DNS اليدوي أو DNS الآمن لجهازك ومتصفحك، فقد تحققت من أن هذا هو الإعداد المقصود.
  • نظام التشغيل والمتصفح وتطبيقات StageVPN وملحقاتها محدثة.
  • نفس النتيجة حتى بعد التبديل بين Wi-Fi وبيانات الجوال وإعادة تشغيل المتصفح.
  • إذا كنت بحاجة إلى حماية البرامج خارج Chrome، فيمكنك استخدام VPN على مستوى الجهاز بدلاً من الإضافة.

ومن الجيد أيضًا تحديد متى تكون إعادة الفحص ضرورية. وذلك بعد إجراء تحديث رئيسي لنظام التشغيل أو المتصفح لديك، أو بعد تثبيت ملحق جديد أو تطبيق أمان، أو قبل القيام بأي عمل حساس على الشبكة التي تتصل بها لأول مرة. إذا كانت الإعدادات هي نفسها ولكن النتائج تغيرت، فعادةً ما يكون أحد هذه الأشياء الثلاثة هو السبب. بمجرد أن تتقن ذلك، يمكن إكمال مراحل التشخيص الستة في دقائق معدودة.

إذا استمرت المشكلة، فقم بتنظيم طراز الجهاز ونظام التشغيل وإصدار التطبيق ووقت حدوثها ونتائج الاختبار. دعم العملاءيرجى الاتصال بنا. من فضلك لا ترسل كلمة المرور أو رمز التحقق. إعدادات الجهاز المراد فحصها مع التحقق من عدم وجود تسربات هي: 10 إعدادات خصوصية للهواتف الذكيةحسنًا، هناك مخاطر لا يمكن حلها باستخدام VPN فقط. ما الذي تمنعه ​​شبكات VPN وما لا يمكنها منعهحسنا، عاداتك على الشبكات العامة هي قواعد سلامة شبكات الواي فاي العامةلقد نظمته في .

المواد المرجعية

  1. RFC 1034: أسماء النطاقات – المفاهيم والمرافق - بنية DNS ودور المحللين (IETF)
  2. RFC 8484: استعلامات DNS عبر HTTPS (DoH) - كيفية تشفير استعلامات DNS عبر HTTPS (IETF)
  3. RFC 7858: DNS عبر TLS - كيفية تشفير استعلامات DNS باستخدام TLS (IETF)
  4. RFC 8445: مؤسسة الاتصال التفاعلي (ICE) - أنواع مرشحات اتصال WebRTC وإجراءات التجميع (IETF)
  5. RFC 8828: متطلبات معالجة عنوان WebRTC IP - نطاق العناوين التي تعرضها المتصفحات لـ WebRTC (IETF)
  6. واجهة برمجة تطبيقات chrome.privacy - قيم سياسة معالجة Chrome WebRTC IP (Chrome للمطورين)
  7. واجهة برمجة تطبيقات chrome.proxy — إعدادات وكيل الامتداد وقائمة التجاوز وأولويات التحكم (Chrome للمطورين)
  8. واجهة برمجة تطبيقات WebRTC — RTCPeerConnection ومفهوم مرشحي ICE (MDN Web Docs)
  • #تسرب DNS
  • تسريب #WebRTC
  • #تسرب DNS
  • #اختبار تسرب IP
  • #إعدادات VPN